fjkfhjfjhfjhfjh

Jul 17

Visual Studio help needed

13 comments

I've never used VS before (I was using Notepad++ for AMOS 2, as VS is Microsoft, and therefore I automatically hate it), but after seeing Francois's video I thought I'd give it a go.

I installed it and followed his video. I have Ctrl+F2 compiling, but Ctrl+F1 doesn't do anything. Is there something I need to look at to see what that command it actually trying to run?

Jul 24

Hey Paul. Sorry for the late answer, just catching up after my resignation from Q-Loc. If Ctrl-F1 does not work, it may mean that it cannot find run.bat at the root of the AMOS-2 directory. OR that you have a conflict in the keyboard shortcuts: open the shortcut list, type F1 in the search bar, and find if Ctrl-F1 is already assigned to something else. If yes, then right click on it and choose "remove". If both conditions are met, it should work. Note that the current file in VSCode must be a .amos file to work...

I found the problem. For some reason I didn't have the line:

"command": "workbench.action.tasks.runTask",

for the ctrl+f1 part.

I don't use Chrome, so I'd already changed the run.bat to run vivaldi.exe instead.

I just need elseifs to work now, so I can run my Breakout/Arkanoid game again.

I've also never seen Visual Studio Code before. Can I have a real 'Beginners Guide' to setting it up for Amos2, please? I tried to follow FL's video but I still do not understand what I'm doing.

Oct 25

The Youtube channel has it : I am a beginner to VSC too, and this video from Francois did the job very well, and once it works, it's really easy to compile a main.amos file with ctrl+F2, and run it with ctrl+F1. Follow the link, and tell us if you succeed :

https://www.youtube.com/watch?v=lsxe-3O6NDs

 

Thank you, I tried to follow FL's video but I still do not understand what I'm doing.

Oct 26

Yes, sorry it is rather difficult. If I have time, I will have a look at Atom... It is also a good editor, and configuration seems to be a lot simpler. Installation should be simple.

Oct 27

Check your folder : do you have this executable installed ?

If node, download the windows version of Amos into the "Download" section of the https://www.amos2.org.

If you got Amos from the bitbucket website, the executable of the compiler is missing.

 

Hope this helps.

 

PS : I will publish soon a (very) little and simple "web-based IDE" to allow you to play with AMOS-2 without having to install anything on your PC. Hope this will help newcomers to AMOS-2 too.

Oct 28

Why would you need to install node.js? I see absolutely no reason. I publish a video today explaining where I am. New version soon, installation will be a lot simpler... I have seen and used Baptiste online-IDE, very smart and simple... (Y)

I'm frustrated. I'm keen to get something written in A2!

I've downloaded the package again, from the forum link. Things are better; VSC does the debug but I get no output. I think a browser window should open and run the prog? My preferred browser is Firefox, but I see the default is set to Chrome. I have Chrome installed but i have no output either way.

New Posts